HP 70004A Power Supply Repair

I bought this cheap 70004A color display as faulty. I was happy to find it actually worked... or so it did for a few months. One day, it refused to turn on. I could see the power LED flash briefly upon turn-on and then... silence (pretty easy to tell with your eyes closed if this thing is on or off, you know what I mean...). You really need to know what you are doing before probing and testing a thing like this live. You'll probably want to use an isolation transformer and differential probes, and keep one hand on your pocket at all times.


This is the beast on the bench, that PCB looks very timidating to me. High voltage, big and the troubleshooting will need to be done live. I did not know where to start. Many suggested changing every capacitor in the board, something I was not going to do, I wanted to find what the fault really was (all capacitors turned to be ok):






I got the CLIP manual from ArtekMedia as usual. This board is a latter revision than the ones that appear on the schematics but there are not many changes. The block diagram was invaluable, this switching power supplies are complex. I was lucky to have bought a FLUKE D120 differential voltage probe this year at Friedrichshafen to the nice guy with grey hair and glasses that sells mostly Fluke stuff. This paid for itself in just this repair. Something was drawing more current than expected and the current-limit protection was tripping. You can see the power supply slowly increasing the current at turn on until it gets too high before it starts regulating the voltage, and quits. There is a current sense resistor and this is what current looked at turn-on try:




There is no way to check one of the blocks of the power supply alone, you have to give it power and hope for the best. After many hours of testing and probing, and and few components that exploded in the process (most times my fault) I found there was a transformer with a 14 ohm leak between primary and secondary. The supply operates a high switching frequency and many parts of the circuit are shorted at DC, so I could not find this until I took both transformers out. Do you see that suspicious potting that squeezed outside the can in one of them?:




I asked in the HP/Agilent Test Equipment Yahoo group and many people offered help and suggestions. Richard P. even offered savaging one PCB he had and sending the transformer. Thank you!, you all are the reason why I am taking the time to write this. Knowing I had nothing to loose, I went and opened the transformer can with a Dremel, and removed the resin with hot air and tweezers, carefully to not damage the windings. No surpise, the secondary jacket was burned and touching the primary in one spot:






Could this be fixed? I used a thin teflon tube and a copper wire to recreate the four turns that form the secondary and guess what, it worked !!






I confessed before that I killed a few components on the process, and I could not find replacements for some of them:

  • Q1: mhj16012 was replaced with nu508AW
  • CR209: 1n4150 was replaced with 1n4148
  • Q9: 2n2907 was replaced with 2n3906 (back to front)
  • U200: lm393
  • VR201: lm358bz-1.2
  • uln2061 was replaced with uln2074B


This last one required some improvisation because it is a quad-transistor instead of dual, and the DIP package is very different. I built this "adapter" thing as a temporary solution, you too know what that means :-):






And a final picture of the twin transformers in the working power supply. Can you tell one from the other?




Roberto Barrios, EB4EQA